aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
authorLeonardo Mörlein <me@irrelefant.net>2021-05-09 22:28:15 +0200
committerPetr Štetiar <ynezz@true.cz>2021-05-13 15:13:15 +0200
commitb993b68b6ca8444b5227a0c18df4600b37ac565c (patch)
treea55300e2e43a57fa46a534d1135eee006a4b6d71 /package/base-files
parentce8af0ace04bb43e8156940c771b4058fa83d27a (diff)
downloadupstream-b993b68b6ca8444b5227a0c18df4600b37ac565c.tar.gz
upstream-b993b68b6ca8444b5227a0c18df4600b37ac565c.tar.bz2
upstream-b993b68b6ca8444b5227a0c18df4600b37ac565c.zip
build: introduce $(MKHASH)
Before this commit, it was assumed that mkhash is in the PATH. While this was fine for the normal build workflow, this led to some issues if make TOPDIR="$(pwd)" -C "$pkgdir" compile was called manually. In most of the cases, I just saw warnings like this: make: Entering directory '/home/.../package/gluon-status-page' bash: line 1: mkhash: command not found bash: line 1: mkhash: command not found bash: line 1: mkhash: command not found bash: line 1: mkhash: command not found bash: line 1: mkhash: command not found bash: line 1: mkhash: command not found bash: line 1: mkhash: command not found bash: line 1: mkhash: command not found [...] While these were only warnings and the package still compiled sucessfully, I also observed that some package even fail to build because of this. After applying this commit, the variable $(MKHASH) is introduced. This variable points to $(STAGING_DIR_HOST)/bin/mkhash, which is always the correct path. Signed-off-by: Leonardo Mörlein <me@irrelefant.net>
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 8a1ddf96f5..d8d093a306 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -30,7 +30,7 @@ PKG_CONFIG_DEPENDS += \
include $(INCLUDE_DIR)/package.mk
ifneq ($(DUMP),1)
- STAMP_CONFIGURED:=$(strip $(STAMP_CONFIGURED))_$(shell echo $(CONFIG_TARGET_INIT_PATH) | mkhash md5)
+ STAMP_CONFIGURED:=$(strip $(STAMP_CONFIGURED))_$(shell echo $(CONFIG_TARGET_INIT_PATH) | $(MKHASH) md5)
TARGET:=-$(BOARD)
endif