aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-07-31 18:11:55 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-07-31 18:11:55 +0000
commitb7f8f212ae2207de3e709445b158aec1ec263a3b (patch)
tree5b0b3a41828c06f5891f31e6cca736881b37e128 /package/base-files
parente77339b9e2126e166927f62178fabf13d7346ea6 (diff)
downloadupstream-b7f8f212ae2207de3e709445b158aec1ec263a3b.tar.gz
upstream-b7f8f212ae2207de3e709445b158aec1ec263a3b.tar.bz2
upstream-b7f8f212ae2207de3e709445b158aec1ec263a3b.zip
base-files: implement -l (--list-backup) sysupgrade parameter to list the files that would be backed up
SVN-Revision: 37627
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile2
-rwxr-xr-xpackage/base-files/files/sbin/sysupgrade14
2 files changed, 15 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 93941b9155..3ba30c3abc 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
include $(INCLUDE_DIR)/version.mk
PKG_NAME:=base-files
-PKG_RELEASE:=145
+PKG_RELEASE:=146
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
PKG_BUILD_DEPENDS:=opkg/host
diff --git a/package/base-files/files/sbin/sysupgrade b/package/base-files/files/sbin/sysupgrade
index f6b628e96e..eb5ab035c6 100755
--- a/package/base-files/files/sbin/sysupgrade
+++ b/package/base-files/files/sbin/sysupgrade
@@ -10,6 +10,7 @@ export SAVE_CONFIG=1
export SAVE_OVERLAY=0
export DELAY=
export CONF_IMAGE=
+export CONF_BACKUP_LIST=0
export CONF_BACKUP=
export CONF_RESTORE=
export NEED_IMAGE=
@@ -28,6 +29,7 @@ while [ -n "$1" ]; do
-c) export SAVE_OVERLAY=1;;
-b|--create-backup) export CONF_BACKUP="$2" NEED_IMAGE=1; shift;;
-r|--restore-backup) export CONF_RESTORE="$2" NEED_IMAGE=1; shift;;
+ -l|--list-backup) export CONF_BACKUP_LIST=1; break;;
-f) export CONF_IMAGE="$2"; shift;;
-F|--force) export FORCE=1;;
-T|--test) export TEST=1;;
@@ -75,6 +77,9 @@ backup-command:
restore a .tar.gz created with sysupgrade -b
then exit. Does not flash an image. If file is '-',
the archive is read from stdin.
+ -l | --list-backup
+ list the files that would be backed up when calling
+ sysupgrade -b. Does not create a backup file.
EOF
exit 1
@@ -133,8 +138,17 @@ do_save_conffiles() {
v "Saving config files..."
[ "$VERBOSE" -gt 1 ] && TAR_V="v" || TAR_V=""
tar c${TAR_V}zf "$conf_tar" -T "$CONFFILES" 2>/dev/null
+
+ rm -f "$CONFFILES"
}
+if [ $CONF_BACKUP_LIST -eq 1 ]; then
+ add_uci_conffiles "$CONFFILES"
+ cat "$CONFFILES"
+ rm -f "$CONFFILES"
+ exit 0
+fi
+
if [ -n "$CONF_BACKUP" ]; then
do_save_conffiles "$CONF_BACKUP"
exit $?