aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2021-01-04 18:53:40 +0000
committerDaniel Golle <daniel@makrotopia.org>2021-01-05 02:16:24 +0000
commit9c845a5ad1f20bc19fcc0af1e7d160c3b3f635aa (patch)
tree0e38f925df35f5112061c8178f45b99b958ef0d0 /package/base-files
parentb31ca88de9fed0ad5470b65a13b779ca51463ba3 (diff)
downloadupstream-9c845a5ad1f20bc19fcc0af1e7d160c3b3f635aa.tar.gz
upstream-9c845a5ad1f20bc19fcc0af1e7d160c3b3f635aa.tar.bz2
upstream-9c845a5ad1f20bc19fcc0af1e7d160c3b3f635aa.zip
base-files: wifi: add support for 802.11ad
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile2
-rwxr-xr-xpackage/base-files/files/sbin/wifi1
2 files changed, 2 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index da3976424f..8d40eb0e49 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/version.mk
include $(INCLUDE_DIR)/feeds.mk
PKG_NAME:=base-files
-PKG_RELEASE:=244
+PKG_RELEASE:=245
PKG_FLAGS:=nonshared
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
diff --git a/package/base-files/files/sbin/wifi b/package/base-files/files/sbin/wifi
index a8b4451c60..75759b94f3 100755
--- a/package/base-files/files/sbin/wifi
+++ b/package/base-files/files/sbin/wifi
@@ -79,6 +79,7 @@ wifi_fixup_hwmode() {
case "$hwmode" in
11bg) hwmode=bg;;
11a) hwmode=a;;
+ 11ad) hwmode=ad;;
11b) hwmode=b;;
11g) hwmode=g;;
11n*)