aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2013-02-01 12:28:24 +0000
committerSteven Barth <cyrus@openwrt.org>2013-02-01 12:28:24 +0000
commit92ad26d1b6b65d33555c773374687f49f55b929c (patch)
treedcd09431b6348bf7042923e6f8080e220d3778f5 /package/base-files
parent416ce374c031979ddd5e2f376ea6f88232f66178 (diff)
downloadupstream-92ad26d1b6b65d33555c773374687f49f55b929c.tar.gz
upstream-92ad26d1b6b65d33555c773374687f49f55b929c.tar.bz2
upstream-92ad26d1b6b65d33555c773374687f49f55b929c.zip
base-files: Fix IPv6 early sysctls again * Kernel IPv6 /proc interface inconsistency caused races
SVN-Revision: 35417
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile2
-rwxr-xr-xpackage/base-files/files/etc/init.d/boot8
-rw-r--r--package/base-files/files/etc/sysctl_early.conf3
3 files changed, 7 insertions, 6 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 8943c469d8..99db435e86 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
include $(INCLUDE_DIR)/version.mk
PKG_NAME:=base-files
-PKG_RELEASE:=130
+PKG_RELEASE:=131
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
PKG_BUILD_DEPENDS:=opkg/host
diff --git a/package/base-files/files/etc/init.d/boot b/package/base-files/files/etc/init.d/boot
index 1800342367..005c4ad6f8 100755
--- a/package/base-files/files/etc/init.d/boot
+++ b/package/base-files/files/etc/init.d/boot
@@ -96,8 +96,12 @@ start() {
[ -n "$rootdev" ] && ln -s "$rootdev" /dev/root
}
- # run early sysctl
- [ -f /etc/sysctl_early.conf ] && sysctl -p /etc/sysctl_early.conf -e >&-
+ # early sysctl to avoid networking races
+ if [ -d /proc/sys/net/ipv6/conf ]; then
+ for i in /proc/sys/net/ipv6/conf/*/accept_ra; do
+ echo 0 > $i
+ done
+ fi
}
stop() {
diff --git a/package/base-files/files/etc/sysctl_early.conf b/package/base-files/files/etc/sysctl_early.conf
deleted file mode 100644
index 6f2eeea040..0000000000
--- a/package/base-files/files/etc/sysctl_early.conf
+++ /dev/null
@@ -1,3 +0,0 @@
-# Avoid race-conditions with SLAAC
-net.ipv6.conf.default.accept_ra=0
-net.ipv6.conf.all.accept_ra=0