aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-01-04 01:28:44 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-01-07 19:51:50 +0100
commit81655e1450a80276db32c8a8e10de73a256bc664 (patch)
treea3219323562bf2038daa4b7c893210fd2de5ab2d /package/base-files
parent51360a913b492d042a697a9658a21f820a027fa1 (diff)
downloadupstream-81655e1450a80276db32c8a8e10de73a256bc664.tar.gz
upstream-81655e1450a80276db32c8a8e10de73a256bc664.tar.bz2
upstream-81655e1450a80276db32c8a8e10de73a256bc664.zip
base-files: read all 3 bytes in get_magic_vfat() at once
While the speed improvement might be negligible, there is still no reason to read individual bytes. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile2
-rw-r--r--package/base-files/files/lib/upgrade/common.sh2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 8d40eb0e49..f18f221129 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/version.mk
include $(INCLUDE_DIR)/feeds.mk
PKG_NAME:=base-files
-PKG_RELEASE:=245
+PKG_RELEASE:=246
PKG_FLAGS:=nonshared
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
diff --git a/package/base-files/files/lib/upgrade/common.sh b/package/base-files/files/lib/upgrade/common.sh
index e8a28f4138..c28bae48a1 100644
--- a/package/base-files/files/lib/upgrade/common.sh
+++ b/package/base-files/files/lib/upgrade/common.sh
@@ -130,7 +130,7 @@ get_magic_gpt() {
}
get_magic_vfat() {
- (get_image "$@" | dd bs=1 count=3 skip=54) 2>/dev/null
+ (get_image "$@" | dd bs=3 count=1 skip=18) 2>/dev/null
}
get_magic_fat32() {