aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2011-11-10 12:55:01 +0000
committerImre Kaloz <kaloz@openwrt.org>2011-11-10 12:55:01 +0000
commit7944b6fa3291e8743641398ed47e76d5d3873e89 (patch)
treee687b62f943e4d90568d77375b5b433ef110fa49 /package/base-files
parent55ac5299513c6f565504a84d3a5858056db5a965 (diff)
downloadupstream-7944b6fa3291e8743641398ed47e76d5d3873e89.tar.gz
upstream-7944b6fa3291e8743641398ed47e76d5d3873e89.tar.bz2
upstream-7944b6fa3291e8743641398ed47e76d5d3873e89.zip
enable and use shadow passwords by default
SVN-Revision: 28936
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 6e41f04589..da9e6f3727 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=base-files
-PKG_RELEASE:=91
+PKG_RELEASE:=92
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
PKG_BUILD_DEPENDS:=opkg/host
@@ -455,10 +455,9 @@ define Package/base-files/install
)
# Form valid /etc/shadow entries, by copying the user:pw pairs
# from /etc/passwd, and adding on pw change data
- $(if $(CONFIG_BUSYBOX_CONFIG_FEATURE_SHADOWPASSWDS), \
- cut -d ':' -f 1-2 $(1)/etc/passwd > $(1)/etc/shadow; \
- $(SED) 's/$$$$/:13848:0:99999:7:::/' $(1)/etc/shadow \
- )
+ cut -d ':' -f 1-2 $(1)/etc/passwd > $(1)/etc/shadow; \
+ $(SED) 's/$$$$/:0:0:99999:7:::/' $(1)/etc/shadow
+
$(SED) 's,$$$$R,$(REVISION),g' $(1)/etc/banner
mkdir -p $(1)/CONTROL
mkdir -p $(1)/dev