aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-10-27 07:54:49 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-10-27 07:54:49 +0000
commit4cc48089c75b377e6f5be3fca2bb242486fb579f (patch)
tree309d0b364bed62511a2b3a4bd4b409083abe02e8 /package/base-files
parentd02f22fea1653a83fa053cc86b73bc82ad6759c3 (diff)
downloadupstream-4cc48089c75b377e6f5be3fca2bb242486fb579f.tar.gz
upstream-4cc48089c75b377e6f5be3fca2bb242486fb579f.tar.bz2
upstream-4cc48089c75b377e6f5be3fca2bb242486fb579f.zip
base-files/sysupgrade: add more busybox applet symlinks to ramdisk
Adds symlinks for printf and wc to make life happier in the sysupgrade ramdisk. Also make code more readable by escaping that overly long line. Signed-off-by: Daniel Golle <dgolle@allnet.de> SVN-Revision: 28616
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile2
-rw-r--r--package/base-files/files/lib/upgrade/common.sh7
2 files changed, 7 insertions, 2 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 002d51674d..7e895f1d31 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=base-files
-PKG_RELEASE:=83
+PKG_RELEASE:=84
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
PKG_BUILD_DEPENDS:=opkg/host
diff --git a/package/base-files/files/lib/upgrade/common.sh b/package/base-files/files/lib/upgrade/common.sh
index 11e1b2cdfa..65ce816db2 100644
--- a/package/base-files/files/lib/upgrade/common.sh
+++ b/package/base-files/files/lib/upgrade/common.sh
@@ -48,7 +48,12 @@ pivot() { # <new_root> <old_root>
}
run_ramfs() { # <command> [...]
- install_bin /bin/busybox /bin/ash /bin/sh /bin/mount /bin/umount /sbin/pivot_root /usr/bin/wget /sbin/reboot /bin/sync /bin/dd /bin/grep /bin/cp /bin/mv /bin/tar /usr/bin/md5sum "/usr/bin/[" /bin/vi /bin/ls /bin/cat /usr/bin/awk /usr/bin/hexdump /bin/sleep /bin/zcat /usr/bin/bzcat
+ install_bin /bin/busybox /bin/ash /bin/sh /bin/mount /bin/umount \
+ /sbin/pivot_root /usr/bin/wget /sbin/reboot /bin/sync /bin/dd \
+ /bin/grep /bin/cp /bin/mv /bin/tar /usr/bin/md5sum "/usr/bin/[" \
+ /bin/vi /bin/ls /bin/cat /usr/bin/awk /usr/bin/hexdump \
+ /bin/sleep /bin/zcat /usr/bin/bzcat /usr/bin/printf /usr/bin/wc
+
install_bin /sbin/mtd
for file in $RAMFS_COPY_BIN; do
install_bin $file