aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-01-16 13:39:13 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-01-16 13:39:13 +0000
commit35f17d4c9b7e6c69cd2dbcbd41e6bde168699779 (patch)
tree28f20e70a030e87c69583f592016649b8514e0ad /package/base-files
parent5af2db9ce50de49804ec4f47bee966e8eb9525f7 (diff)
downloadupstream-35f17d4c9b7e6c69cd2dbcbd41e6bde168699779.tar.gz
upstream-35f17d4c9b7e6c69cd2dbcbd41e6bde168699779.tar.bz2
upstream-35f17d4c9b7e6c69cd2dbcbd41e6bde168699779.zip
[package] base-files:
sysupgade library coomon.sh has "bug" in glibc enviorement. For some reason ld-linux.so.3 is not installed at ramfs and sysupgrade always fails. Signed-off-by: Zintis Petersons <zintis.petersons@e-mail.lv> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19167 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile2
-rw-r--r--package/base-files/files/lib/upgrade/common.sh3
2 files changed, 4 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 67837120b6..ea2b5a47f1 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=base-files
-PKG_RELEASE:=34
+PKG_RELEASE:=35
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
diff --git a/package/base-files/files/lib/upgrade/common.sh b/package/base-files/files/lib/upgrade/common.sh
index ff3012bcc1..3beb6484d8 100644
--- a/package/base-files/files/lib/upgrade/common.sh
+++ b/package/base-files/files/lib/upgrade/common.sh
@@ -21,6 +21,9 @@ install_bin() { # <file> [ <symlink> ... ]
files=$1
[ -x "$src" ] && files="$src $(libs $src)"
install_file $files
+ [ -e /lib/ld-linux.so.3 ] && {
+ install_file /lib/ld-linux.so.3
+ }
shift
for link in "$@"; do {
dest="$RAM_ROOT/$link"