aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2013-06-11 14:10:45 +0000
committerSteven Barth <cyrus@openwrt.org>2013-06-11 14:10:45 +0000
commit33c620773dba85ccc93dad328b71aaee54bbbb3b (patch)
treee11ab0d4b048cdecc257d630b9611aeeb3536718 /package/base-files
parente2f33bedfa316a5b202d14bd45b8feb17718069b (diff)
downloadupstream-33c620773dba85ccc93dad328b71aaee54bbbb3b.tar.gz
upstream-33c620773dba85ccc93dad328b71aaee54bbbb3b.tar.bz2
upstream-33c620773dba85ccc93dad328b71aaee54bbbb3b.zip
base-files: remove unnecessary early sysctl-hack
SVN-Revision: 36920
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile2
-rwxr-xr-xpackage/base-files/files/etc/init.d/boot7
2 files changed, 1 insertions, 8 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index f06c12fcb5..ec008c5ef0 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
include $(INCLUDE_DIR)/version.mk
PKG_NAME:=base-files
-PKG_RELEASE:=140
+PKG_RELEASE:=141
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
PKG_BUILD_DEPENDS:=opkg/host
diff --git a/package/base-files/files/etc/init.d/boot b/package/base-files/files/etc/init.d/boot
index 4f35eac7b3..d33e8ce7f8 100755
--- a/package/base-files/files/etc/init.d/boot
+++ b/package/base-files/files/etc/init.d/boot
@@ -72,11 +72,4 @@ start() {
rootdev=$(awk 'BEGIN { RS=" "; FS="="; } $1 == "root" { print $2 }' < /proc/cmdline)
[ -n "$rootdev" ] && ln -s "$rootdev" /dev/root
}
-
- # early sysctl to avoid networking races
- if [ -d /proc/sys/net/ipv6/conf ]; then
- for i in /proc/sys/net/ipv6/conf/*/accept_ra; do
- echo 0 > $i
- done
- fi
}