aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-07-24 15:47:15 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-07-24 15:47:15 +0000
commit2f4e4586d2917c2245517e528396972af6d9a12e (patch)
tree93af111863badb152aba22434fe28a43949204de /package/base-files
parent23d200d6f26f3b42dc6b0852c72022319c42ee8b (diff)
downloadupstream-2f4e4586d2917c2245517e528396972af6d9a12e.tar.gz
upstream-2f4e4586d2917c2245517e528396972af6d9a12e.tar.bz2
upstream-2f4e4586d2917c2245517e528396972af6d9a12e.zip
[package] base-files: unconditionally unlock the rootfs_data partition (#7437)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22377 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile2
-rw-r--r--package/base-files/files/lib/preinit/40_mount_jffs21
2 files changed, 2 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 24bbf188c3..137eb62a2f 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=base-files
-PKG_RELEASE:=50
+PKG_RELEASE:=51
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
diff --git a/package/base-files/files/lib/preinit/40_mount_jffs2 b/package/base-files/files/lib/preinit/40_mount_jffs2
index cb743ea75c..d2f05b02ce 100644
--- a/package/base-files/files/lib/preinit/40_mount_jffs2
+++ b/package/base-files/files/lib/preinit/40_mount_jffs2
@@ -5,6 +5,7 @@
find_mount_jffs2() {
mkdir -p /tmp/overlay
mount "$(find_mtd_part rootfs_data)" /tmp/overlay -t jffs2
+ mtd -qq unlock rootfs_data
}
jffs2_not_mounted() {