aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2020-12-20 18:02:53 +0100
committerDaniel Golle <daniel@makrotopia.org>2020-12-20 17:14:56 +0000
commit20d847d1338f716fc9f143f633b6f79ba6017b5c (patch)
treec941cc20705c4aa9539b957416fff4195a050452 /package/base-files
parent7a181a65f2e5d19e379cebbb980aa2f2985709e2 (diff)
downloadupstream-20d847d1338f716fc9f143f633b6f79ba6017b5c.tar.gz
upstream-20d847d1338f716fc9f143f633b6f79ba6017b5c.tar.bz2
upstream-20d847d1338f716fc9f143f633b6f79ba6017b5c.zip
base-files: upgrade: fix initramfs detection
Commit "initramfs: switch to tmpfs to fix ujail" switched initramfs to now use tmpfs, it causes $(rootfs_type) to now return tmpfs when running initramfs image instead of being empty. This broke initramfs detection which prevents config files from being saved as it does not work from initramfs. So, lets test for $(rootfs_type) returning "tmpfs" instead. Fixes: 7fd3c68 ("initramfs: switch to tmpfs to fix ujail) Signed-off-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile2
-rwxr-xr-xpackage/base-files/files/sbin/sysupgrade2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index fbcb694592..fb1267ea5b 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/version.mk
include $(INCLUDE_DIR)/feeds.mk
PKG_NAME:=base-files
-PKG_RELEASE:=240
+PKG_RELEASE:=241
PKG_FLAGS:=nonshared
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
diff --git a/package/base-files/files/sbin/sysupgrade b/package/base-files/files/sbin/sysupgrade
index ca2eb298dc..3300d8e1ea 100755
--- a/package/base-files/files/sbin/sysupgrade
+++ b/package/base-files/files/sbin/sysupgrade
@@ -216,7 +216,7 @@ include /lib/upgrade
do_save_conffiles() {
local conf_tar="$1"
- [ -z "$(rootfs_type)" ] && {
+ [ "$(rootfs_type)" = "tmpfs" ] && {
echo "Cannot save config while running from ramdisk." >&2
ask_bool 0 "Abort" && exit
rm -f "$conf_tar"