aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
authorKyle Copperfield <kmcopper@danwin1210.me>2019-11-19 18:50:00 +0000
committerJohn Crispin <john@phrozen.org>2020-01-15 20:04:06 +0100
commit0da193ee6943fc7afd100d2378cd1989d1f1cc03 (patch)
tree8d5a59fd1639848047cb0fc801a140984a5fef49 /package/base-files
parentf704f97e4c57e3f2db1bd2f5c87e1e44aebba42b (diff)
downloadupstream-0da193ee6943fc7afd100d2378cd1989d1f1cc03.tar.gz
upstream-0da193ee6943fc7afd100d2378cd1989d1f1cc03.tar.bz2
upstream-0da193ee6943fc7afd100d2378cd1989d1f1cc03.zip
dropbear: move failsafe code out of base-files
The sender domain has a DMARC Reject/Quarantine policy which disallows sending mailing list messages using the original "From" header. To mitigate this problem, the original message has been wrapped automatically by the mailing list software. Failsafe code of dropbear should be in the dropbear package not the base-files package. Signed-off-by: Kyle Copperfield <kmcopper@danwin1210.me>
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile2
-rw-r--r--package/base-files/files/lib/preinit/99_10_failsafe_login6
2 files changed, 1 insertions, 7 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 268d7d4cc9..e389148d47 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/version.mk
include $(INCLUDE_DIR)/feeds.mk
PKG_NAME:=base-files
-PKG_RELEASE:=212
+PKG_RELEASE:=213
PKG_FLAGS:=nonshared
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
diff --git a/package/base-files/files/lib/preinit/99_10_failsafe_login b/package/base-files/files/lib/preinit/99_10_failsafe_login
index 728c63b2e8..16ad84f4ba 100644
--- a/package/base-files/files/lib/preinit/99_10_failsafe_login
+++ b/package/base-files/files/lib/preinit/99_10_failsafe_login
@@ -2,11 +2,6 @@
# Copyright (C) 2006-2015 OpenWrt.org
# Copyright (C) 2010 Vertical Communications
-failsafe_netlogin () {
- dropbearkey -t rsa -s 1024 -f /tmp/dropbear_failsafe_host_key
- dropbear -r /tmp/dropbear_failsafe_host_key <> /dev/null 2>&1
-}
-
failsafe_shell() {
local console="$(sed -e 's/ /\n/g' /proc/cmdline | grep '^console=' | head -1 | sed -e 's/^console=//' -e 's/,.*//')"
[ -n "$console" ] || console=console
@@ -17,5 +12,4 @@ failsafe_shell() {
done &
}
-boot_hook_add failsafe failsafe_netlogin
boot_hook_add failsafe failsafe_shell