aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files/files/etc
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-04-12 17:31:16 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-04-12 17:31:16 +0000
commita43ae30e1bebe4d502ff1da4e715dd4cabcde83c (patch)
tree55deb2adeee13f388c7ae1f549cb498435bdd0a8 /package/base-files/files/etc
parent8b7533c496b37c075bf17921a702eb8deb2a5fae (diff)
downloadupstream-a43ae30e1bebe4d502ff1da4e715dd4cabcde83c.tar.gz
upstream-a43ae30e1bebe4d502ff1da4e715dd4cabcde83c.tar.bz2
upstream-a43ae30e1bebe4d502ff1da4e715dd4cabcde83c.zip
include, base-files, opkg: introduce version configuration to override the embedded version info of generated images - Introduce new Kconfig symbols VERSION_DIST, VERSION_NICK, VERSION_NUMBER and VERSION_REPO to specify distribution, release name, version and repository for a given build - Introduce include/version.mk to provide common helpers for packages dealing with versions - Make opkg use version.mk to populate the opkg.conf template - Make base-files use version.mk to populate /etc/openwrt_version, /etc/openwrt_release and /etc/banner
The available placeholders are: %D .. Replace with $(CONFIG_VERSION_DIST), default to "OpenWrt" %d .. Like %D, but all characters made lowercase and spaces substituted with "_" (e.g. "openwrt") %N .. Replace with $(CONFIG_VERSION_NICK), default to the build tree release (e.g. "Attitude Adjustment") %n .. Like %N, but all characters made lowercase and spaces substituted with "_" (e.g. "attitude_adjustment") %V .. Replace with $(CONFIG_VERSION_NUMBER), default to the build tree release (e.g. "r31262") %v .. Like %V, but all characters made lowercase and spaces substituted with "_" %C .. Replace with $(CONFIG_VERSION_NUMBER), default to "Bleeding Edge" %c .. Like %C, but all characters made lowercase and spaces substituted with "_" (e.g. "bleeding_edge") %U .. Replace with $(CONFIG_VERSION_REPO), default to "http://downloads.openwrt.org/snapshots/trunk/%T/packages" %R .. Replace with the current build tree revision (e.g. "r31262" or "75488c4a05b8033cf69e91874a61852db7ba9c6c") %T .. Replace with the current target (e.g. "ar71xx") %S .. Replace with the current target/subtarget combo (e.g. "adm5120/router_le") SVN-Revision: 31262
Diffstat (limited to 'package/base-files/files/etc')
-rw-r--r--package/base-files/files/etc/banner2
-rw-r--r--package/base-files/files/etc/openwrt_release6
-rw-r--r--package/base-files/files/etc/openwrt_version1
3 files changed, 8 insertions, 1 deletions
diff --git a/package/base-files/files/etc/banner b/package/base-files/files/etc/banner
index efee88596f..3018615682 100644
--- a/package/base-files/files/etc/banner
+++ b/package/base-files/files/etc/banner
@@ -3,7 +3,7 @@
| - || _ | -__| || | | || _|| _|
|_______|| __|_____|__|__||________||__| |____|
|__| W I R E L E S S F R E E D O M
- ATTITUDE ADJUSTMENT (bleeding edge, $R) ----------
+ ATTITUDE ADJUSTMENT (%C, %R) ----------
* 1/4 oz Vodka Pour all ingredients into mixing
* 1/4 oz Gin tin with ice, strain into glass.
* 1/4 oz Amaretto
diff --git a/package/base-files/files/etc/openwrt_release b/package/base-files/files/etc/openwrt_release
new file mode 100644
index 0000000000..8ad2d9d4f6
--- /dev/null
+++ b/package/base-files/files/etc/openwrt_release
@@ -0,0 +1,6 @@
+DISTRIB_ID="%D"
+DISTRIB_RELEASE="%C"
+DISTRIB_REVISION="%R"
+DISTRIB_CODENAME="%n"
+DISTRIB_TARGET="%S"
+DISTRIB_DESCRIPTION="%D %N %V"
diff --git a/package/base-files/files/etc/openwrt_version b/package/base-files/files/etc/openwrt_version
new file mode 100644
index 0000000000..4b14f596fb
--- /dev/null
+++ b/package/base-files/files/etc/openwrt_version
@@ -0,0 +1 @@
+%V