aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorPhilip Prindeville <philipp@redfish-solutions.com>2018-01-24 17:33:21 -0700
committerJo-Philipp Wich <jo@mein.io>2018-02-02 13:59:34 +0100
commitff8e9a4ecbe70564c8649ea4ed69f28bec77dfa7 (patch)
treed501f58707acf6d423fd79f231c6f0dffb38003c /package/base-files/Makefile
parentabbb07a6616afa942d69d8b612cfad90213d40eb (diff)
downloadupstream-ff8e9a4ecbe70564c8649ea4ed69f28bec77dfa7.tar.gz
upstream-ff8e9a4ecbe70564c8649ea4ed69f28bec77dfa7.tar.bz2
upstream-ff8e9a4ecbe70564c8649ea4ed69f28bec77dfa7.zip
treewide: combine VERSION_SED and VERSION_SED_SCRIPT
We don't need two versions of this. The escaping quotes is so that the sed commands aren't misinterpreted by shell; it has nothing to do with the contents of the file, thus one version is adequate. Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index ed34480948..ab21213b51 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -137,7 +137,7 @@ define Package/base-files/install
fi; \
)
- $(VERSION_SED) \
+ $(VERSION_SED_SCRIPT) \
$(1)/etc/banner \
$(1)/etc/openwrt_version \
$(1)/usr/lib/os-release
@@ -194,7 +194,7 @@ define Package/base-files/install
$(if $(CONFIG_CLEAN_IPKG),, \
mkdir -p $(1)/etc/opkg; \
$(call FeedSourcesAppend,$(1)/etc/opkg/distfeeds.conf); \
- $(VERSION_SED) $(1)/etc/opkg/distfeeds.conf)
+ $(VERSION_SED_SCRIPT) $(1)/etc/opkg/distfeeds.conf)
endef
ifneq ($(DUMP),1)