aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorJonas Gorski <jonas.gorski@gmail.com>2017-12-13 14:41:28 +0100
committerJonas Gorski <jonas.gorski@gmail.com>2017-12-13 14:59:07 +0100
commitef1f6092e0ec889b105c4c22cf2a0df1bde99d00 (patch)
tree56249c70d9581b0b6c975ffbae7b3a095a795af7 /package/base-files/Makefile
parent5538b4df7fdc3c184110880bb323f074dc4a6bee (diff)
downloadupstream-ef1f6092e0ec889b105c4c22cf2a0df1bde99d00.tar.gz
upstream-ef1f6092e0ec889b105c4c22cf2a0df1bde99d00.tar.bz2
upstream-ef1f6092e0ec889b105c4c22cf2a0df1bde99d00.zip
base-files: make including distfeeds.conf optional
To not clutter the system when building an opkg free image, generate the distfeeds.conf only if CLEAN_IPKG is unset. Since opkg is now a shared package, we can't rely on PACKAGE_opkg, but since opkg is not reasonably usable without the status information, we can tie the distfeeds.conf to it. Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 2cf76b1b7c..728d787e09 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -23,6 +23,7 @@ PKG_LICENSE:=GPL-2.0
PKG_CONFIG_DEPENDS += \
CONFIG_SIGNED_PACKAGES CONFIG_TARGET_INIT_PATH CONFIG_TARGET_PREINIT_DISABLE_FAILSAFE \
CONFIG_NAND_SUPPORT \
+ CONFIG_CLEAN_IPKG \
CONFIG_PER_FEED_REPO \
CONFIG_PER_FEED_REPO_ADD_DISABLED \
CONFIG_PER_FEED_REPO_ADD_COMMENTED \
@@ -190,9 +191,10 @@ define Package/base-files/install
echo -e "# Build configuration for board $(BOARD)/$(SUBTARGET)/$(PROFILE)\n" >$(1)/etc/build.config; \
cat $(BIN_DIR)/config.seed >>$(1)/etc/build.config)
- mkdir -p $(1)/etc/opkg
- $(call FeedSourcesAppend,$(1)/etc/opkg/distfeeds.conf)
- $(VERSION_SED) $(1)/etc/opkg/distfeeds.conf
+ $(if $(CONFIG_CLEAN_IPKG),, \
+ mkdir -p $(1)/etc/opkg; \
+ $(call FeedSourcesAppend,$(1)/etc/opkg/distfeeds.conf); \
+ $(VERSION_SED) $(1)/etc/opkg/distfeeds.conf)
endef
ifneq ($(DUMP),1)