aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorKuan-Yi Li <kyli@abysm.org>2019-08-11 03:23:28 +0800
committerJo-Philipp Wich <jo@mein.io>2020-06-18 20:08:18 +0200
commitc5bf9a8ced6567c6bd9da63c6ff4c4f2f87207fd (patch)
tree11ec73d45b245227c428684b2d31ea4994fdd4b6 /package/base-files/Makefile
parenta4c0767fbc50ea50f1f0c5adfa35d1c8d347462b (diff)
downloadupstream-c5bf9a8ced6567c6bd9da63c6ff4c4f2f87207fd.tar.gz
upstream-c5bf9a8ced6567c6bd9da63c6ff4c4f2f87207fd.tar.bz2
upstream-c5bf9a8ced6567c6bd9da63c6ff4c4f2f87207fd.zip
base-files: gpio switch: add named GPIO support
Previously, gpio_switch only accepts GPIO pin number as input. Once a GPIO pin is exported and named by device tree, its pin state cannot be configured and saved across reboots by UCI. This patch adds support for named GPIO pins. Thus GPIO pin can be exported by device tree with active high/low correctly configured, having human-readable name in /sys/class/gpio/ is also now possible. More importantly, GPIO pins which are referenced by name will be immune from pin mapping breakage while unintentional pin number changes are introduced by kernel or driver updates. Signed-off-by: Kuan-Yi Li <kyli@abysm.org>
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 5bf783d0e8..84fbcacdfc 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/version.mk
include $(INCLUDE_DIR)/feeds.mk
PKG_NAME:=base-files
-PKG_RELEASE:=222
+PKG_RELEASE:=223
PKG_FLAGS:=nonshared
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/