aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-10-20 22:22:59 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-10-20 22:22:59 +0000
commitb2f4f696bfbca60cb0825da725c483f559975e65 (patch)
tree066a4516139842b415b7bf378a8040202e4df804 /package/base-files/Makefile
parente9aa394113eaaae9323b720f86bde4199ae01149 (diff)
downloadupstream-b2f4f696bfbca60cb0825da725c483f559975e65.tar.gz
upstream-b2f4f696bfbca60cb0825da725c483f559975e65.tar.bz2
upstream-b2f4f696bfbca60cb0825da725c483f559975e65.zip
do not relink libresolv, it makes iproute2 barf
SVN-Revision: 18111
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 68cebfed73..5e5066eeaf 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -417,7 +417,7 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
endef
define Package/libc/install_lib
- $(CP) $(filter-out %/libdl_pic.a %/libpthread_pic.a,$(wildcard $(TOOLCHAIN_DIR)/usr/lib/lib*.a)) $(1)/lib/
+ $(CP) $(filter-out %/libdl_pic.a %/libpthread_pic.a %/libresolv_pic.a,$(wildcard $(TOOLCHAIN_DIR)/usr/lib/lib*.a)) $(1)/lib/
$(if $(wildcard $(TOOLCHAIN_DIR)/usr/lib/libc_so.a),$(CP) $(TOOLCHAIN_DIR)/usr/lib/libc_so.a $(1)/lib/libc_pic.a)
$(if $(wildcard $(TOOLCHAIN_DIR)/usr/lib/gcc/*/*/libgcc.map), \
$(CP) $(TOOLCHAIN_DIR)/usr/lib/gcc/*/*/libgcc_pic.a $(1)/lib/libgcc_s_pic.a; \