aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2017-11-09 17:29:56 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2017-11-09 17:42:36 +0800
commitb2aa820b48add74b97e0eab993ede648c43e85db (patch)
treecc81c5e726d0f63d8ee1b8ae5fb292e0e1773908 /package/base-files/Makefile
parenta6e9d146f2bf1434f6645e72a7dc99166b5021fb (diff)
downloadupstream-b2aa820b48add74b97e0eab993ede648c43e85db.tar.gz
upstream-b2aa820b48add74b97e0eab993ede648c43e85db.tar.bz2
upstream-b2aa820b48add74b97e0eab993ede648c43e85db.zip
base-files: fix getting gid from group_add_next
Shell function return code only has range [0, 255]. Other values will be truncated, e.g. return 65536 will have the same effect as return 0 While at it, drop other "return $rc" where rc will almost always take value 0 and whose value current callers actually do not check Fixes FS#988 Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index e6c53e95a4..077bed469d 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
include $(INCLUDE_DIR)/version.mk
PKG_NAME:=base-files
-PKG_RELEASE:=177
+PKG_RELEASE:=178
PKG_FLAGS:=nonshared
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/