aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-10-21 01:47:49 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-10-21 01:47:49 +0000
commit9117bb10f7ef5536163dfa413a3aa799602907ae (patch)
tree23e29d8252f2ea52ba54d8cd62dbc73ee883af37 /package/base-files/Makefile
parenta1172f3c5dc1cd74605cc0dd3027533bb0ff8b58 (diff)
downloadupstream-9117bb10f7ef5536163dfa413a3aa799602907ae.tar.gz
upstream-9117bb10f7ef5536163dfa413a3aa799602907ae.tar.bz2
upstream-9117bb10f7ef5536163dfa413a3aa799602907ae.zip
add an initial (experimental) version of netifd, disabled by default
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28499 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 0f823beee1..b19f694a09 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -34,7 +34,7 @@ endif
define Package/base-files
SECTION:=base
CATEGORY:=Base system
- DEPENDS:=+base-files-network
+ DEPENDS:=+!USE_NETIFD:base-files-network +USE_NETIFD:netifd
TITLE:=Base filesystem for OpenWrt
URL:=http://openwrt.org/
VERSION:=$(PKG_RELEASE)-$(REVISION)
@@ -66,6 +66,11 @@ define Package/base-files/description
This package contains a base filesystem and system scripts for OpenWrt.
endef
+define Package/base-files/config
+ config USE_NETIFD
+ bool "Use netifd instead of the old network init scripts (experimental!)"
+ default n
+endef
define Package/gcc/Default
SECTION:=libs