aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorTony Ambardar <itugrok@yahoo.com>2018-03-07 21:00:45 -0800
committerHans Dedecker <dedeckeh@gmail.com>2018-06-06 15:00:08 +0200
commit73d8a6ab7668173d70adbed45b61be5256c505e1 (patch)
tree95cef7ae0c805ad0c8e94e087aecc3ae4ed1d074 /package/base-files/Makefile
parente52f3e9b13763cbfbd92fca8db0b4d19dc1e309e (diff)
downloadupstream-73d8a6ab7668173d70adbed45b61be5256c505e1.tar.gz
upstream-73d8a6ab7668173d70adbed45b61be5256c505e1.tar.bz2
upstream-73d8a6ab7668173d70adbed45b61be5256c505e1.zip
base-files: fix UCI config parsing and callback handling
There are several long-standing issues present in the UCI shell API as documented in https://wiki.openwrt.org/doc/devel/config-scripting. They relate both to high-level, user-defined callback functions used to process UCI config files, and also to low-level functions used within scripts generally. The related problems have been encountered now and in the past, e.g. https://forum.openwrt.org/viewtopic.php?id=54295, and include: a) UCI parsing option() function and user-defined option_cb() callbacks being erroneously called during processing of "list" config file entries; b) normal usage of the low-level config_set() unexpectedy calling any defined option_cb() if present; and c) handling of the list_cb() not respecting the NO_CALLBACK variable. Root causes include a function stack "inversion", where the low-level config_set() function incorrectly calls the high-level option() function, intended only for processing the "option" keyword of UCI config files. This change addresses the inversion and other issues, making the option handling code more consistent and smaller, and simplifying developers' usage of UCI callbacks. Signed-off-by: Tony Ambardar <itugrok@yahoo.com> Signed-off-by: Hans Dedecker <dedeckeh@gmail.com> [PKG_RELEASE increase]
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 7175daec3a..89ee0be315 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/version.mk
include $(INCLUDE_DIR)/feeds.mk
PKG_NAME:=base-files
-PKG_RELEASE:=190
+PKG_RELEASE:=191
PKG_FLAGS:=nonshared
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/