aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-05-14 23:33:35 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-05-14 23:33:35 +0000
commit5eed1d8f6b6228d738f25de528f005d7716e6d9d (patch)
tree0eb94160ace4bccf86dc7abef54263494d8d2d5b /package/base-files/Makefile
parenta6e7b3cffeaf69fbb0f9fb20f102849dca9d1340 (diff)
downloadupstream-5eed1d8f6b6228d738f25de528f005d7716e6d9d.tar.gz
upstream-5eed1d8f6b6228d738f25de528f005d7716e6d9d.tar.bz2
upstream-5eed1d8f6b6228d738f25de528f005d7716e6d9d.zip
enable netifd by default and add its config variable to PKG_CONFIG_DEPENDS in a few relevant places
SVN-Revision: 31730
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 78ece51d21..ae96ab54b8 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -35,7 +35,7 @@ endif
define Package/base-files
SECTION:=base
CATEGORY:=Base system
- DEPENDS:=+!USE_NETIFD:base-files-network +USE_NETIFD:netifd
+ DEPENDS:=+DISABLE_NETIFD:base-files-network +!DISABLE_NETIFD:netifd
TITLE:=Base filesystem for OpenWrt
URL:=http://openwrt.org/
VERSION:=$(PKG_RELEASE)-$(REVISION)
@@ -63,8 +63,8 @@ define Package/base-files/description
endef
define Package/base-files/config
- config USE_NETIFD
- bool "Use netifd instead of the old network init scripts (experimental!)"
+ config DISABLE_NETIFD
+ bool "Use the old (deprecated) network init scripts instead of netifd"
default n
endef