aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-03-14 19:27:45 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-03-14 19:27:45 +0000
commit4bcca969dc7b68592b02c41bde7a1c04ef80f37f (patch)
treeeb31fe09d20a0c9ece5cfb296ffa6b0d62f2d4d2 /package/base-files/Makefile
parent1e89670f0e2393df89e1a0e351d70ad5c616f00b (diff)
downloadupstream-4bcca969dc7b68592b02c41bde7a1c04ef80f37f.tar.gz
upstream-4bcca969dc7b68592b02c41bde7a1c04ef80f37f.tar.bz2
upstream-4bcca969dc7b68592b02c41bde7a1c04ef80f37f.zip
base-files: link libpthread against libc
SVN-Revision: 26161
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index b7fb07309e..60f9f83b5c 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -362,7 +362,7 @@ ifneq ($(BUILD_LIBGCC),)
"$(wildcard $(TOOLCHAIN_DIR)/lib/libpthread_so.a)" \
"$(patsubst $(TOOLCHAIN_DIR)/lib/%,$(PKG_BUILD_DIR)/%,$(wildcard $(TOOLCHAIN_DIR)/lib/libpthread-*.so))" \
-Wl,-z,nodelete,-z,initfirst,-init=__pthread_initialize_minimal_internal \
- -ldl $(BUILD_LIBGCC) \
+ -ldl -lc $(BUILD_LIBGCC) \
-Wl,-soname=libpthread.so.0
endef
define Build/Compile/libgcc