aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2017-09-30 13:50:44 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2017-09-30 22:22:38 +0200
commit3adafda07c8509267e3321f4861f620ec3b2f37e (patch)
tree4866490c33dd828f45aaaa62e22d07ae4cb5e28a /package/base-files/Makefile
parentfe36f7b0a6dc01f714c7f2b379503f0f491594c4 (diff)
downloadupstream-3adafda07c8509267e3321f4861f620ec3b2f37e.tar.gz
upstream-3adafda07c8509267e3321f4861f620ec3b2f37e.tar.bz2
upstream-3adafda07c8509267e3321f4861f620ec3b2f37e.zip
base-files: create /etc/config/ directory
The /bin/config_generate script and some other scripts are assuming the /etc/config directory exists in the image. This is true in case for example the package firewall, dropbear or dnsmasq are included, which are adding the files under /etc/config/. Without any of these package the system will not boot up fully because the /etc/config/ directory is missing and some init scripts just fail. Make sure all images with the base-files contain a /etc/config/ directory. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> Acked-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 0c0c1cee30..216e45757e 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -148,6 +148,7 @@ define Package/base-files/install
mkdir -p $(1)/CONTROL
mkdir -p $(1)/dev
+ mkdir -p $(1)/etc/config
mkdir -p $(1)/etc/crontabs
mkdir -p $(1)/etc/rc.d
mkdir -p $(1)/overlay