aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorJonas Gorski <jonas.gorski@gmail.com>2017-12-12 11:19:07 +0100
committerJonas Gorski <jonas.gorski@gmail.com>2017-12-13 13:38:19 +0100
commit1cfbd50ff4d401023748c9834845898618e72221 (patch)
tree66ea4dc3c362b902aaa54dd8468277a3b53f904b /package/base-files/Makefile
parenteeeee885fb497bb07041575b78fca4063145edb9 (diff)
downloadupstream-1cfbd50ff4d401023748c9834845898618e72221.tar.gz
upstream-1cfbd50ff4d401023748c9834845898618e72221.tar.bz2
upstream-1cfbd50ff4d401023748c9834845898618e72221.zip
package: move distfeeds.conf from opkg to base-files
All the relevant options used for distfeeds.conf are part of base-files, so it makes more sense to move the file there as well. This has the added benefit that the we can share the opkg package again, reducing the amount of target specific packages. Acked-by: Jo-Philipp Wich <jo@mein.io> Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 5afb02db28..6e8ef58f21 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -9,9 +9,10 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
include $(INCLUDE_DIR)/version.mk
+include $(INCLUDE_DIR)/feeds.mk
PKG_NAME:=base-files
-PKG_RELEASE:=178
+PKG_RELEASE:=179
PKG_FLAGS:=nonshared
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
@@ -21,7 +22,11 @@ PKG_LICENSE:=GPL-2.0
# Extend depends from version.mk
PKG_CONFIG_DEPENDS += \
CONFIG_SIGNED_PACKAGES CONFIG_TARGET_INIT_PATH CONFIG_TARGET_PREINIT_DISABLE_FAILSAFE \
- CONFIG_NAND_SUPPORT
+ CONFIG_NAND_SUPPORT \
+ CONFIG_PER_FEED_REPO \
+ CONFIG_PER_FEED_REPO_ADD_DISABLED \
+ CONFIG_PER_FEED_REPO_ADD_COMMENTED \
+ $(foreach feed,$(FEEDS_INSTALLED),CONFIG_FEED_$(feed))
include $(INCLUDE_DIR)/package.mk
@@ -184,6 +189,9 @@ define Package/base-files/install
$(if $(CONFIG_INCLUDE_CONFIG), \
echo -e "# Build configuration for board $(BOARD)/$(SUBTARGET)/$(PROFILE)\n" >$(1)/etc/build.config; \
cat $(BIN_DIR)/config.seed >>$(1)/etc/build.config)
+
+ $(call FeedSourcesAppend,$(1)/etc/opkg/distfeeds.conf)
+ $(VERSION_SED) $(1)/etc/opkg/distfeeds.conf
endef
ifneq ($(DUMP),1)