aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-06-05 18:02:00 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-06-05 18:02:00 +0000
commit15c52a84fba09deed2cdcbbe54d448eb222c0c6a (patch)
tree4cf4bc5f8db1f76c8acb427be26060712f05fd28 /package/base-files/Makefile
parent8ac33e5cdf0f7fece847d7912adb46889b0bb713 (diff)
downloadupstream-15c52a84fba09deed2cdcbbe54d448eb222c0c6a.tar.gz
upstream-15c52a84fba09deed2cdcbbe54d448eb222c0c6a.tar.bz2
upstream-15c52a84fba09deed2cdcbbe54d448eb222c0c6a.zip
[package] base-files: add permission exceptions, do not clobber shadow permissions - based on patch by Mark Mentovai <mark@moxienet.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32073 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 68c8e0233b..88167b788b 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -470,6 +470,10 @@ define Package/base-files/install
ln -sf /tmp $(1)/var
mkdir -p $(1)/etc
ln -sf /tmp/resolv.conf /tmp/fstab /tmp/TZ $(1)/etc/
+
+ chmod 0600 $(1)/etc/shadow
+ chmod 1777 $(1)/tmp
+
$(call ImageConfigOptions,$(1))
$(call Package/base-files/install-target,$(1))
for conffile in $(1)/etc/config/*; do \