aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2020-04-12 20:28:49 +0100
committerDaniel Golle <daniel@makrotopia.org>2020-04-12 20:35:00 +0100
commit0aa2ecf5b223b838678b61bd2ded9f29903f17b1 (patch)
tree34a6ff04d9bf0acc0a6a16c28dffe80f20754652 /package/base-files/Makefile
parent4e535d81ee9502947fb3f49aad9c1ddf3da010cf (diff)
downloadupstream-0aa2ecf5b223b838678b61bd2ded9f29903f17b1.tar.gz
upstream-0aa2ecf5b223b838678b61bd2ded9f29903f17b1.tar.bz2
upstream-0aa2ecf5b223b838678b61bd2ded9f29903f17b1.zip
base-files: don't ship local build key when on buildbot
Including the local build key in /etc/opkg/keys isn't feasible when building on the buildbot: The included key collides with its copy already in openwrt-keyring which breaks the ImageBuilder. Not including a locally generated key also makes the base-files package more reproducible. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index f0085e5690..156e7bc8b9 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/version.mk
include $(INCLUDE_DIR)/feeds.mk
PKG_NAME:=base-files
-PKG_RELEASE:=217
+PKG_RELEASE:=218
PKG_FLAGS:=nonshared
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
@@ -118,12 +118,14 @@ ifdef CONFIG_SIGNED_PACKAGES
endef
+ifndef CONFIG_BUILDBOT
define Package/base-files/install-key
mkdir -p $(1)/etc/opkg/keys
$(CP) $(BUILD_KEY).pub $(1)/etc/opkg/keys/`$(STAGING_DIR_HOST)/bin/usign -F -p $(BUILD_KEY).pub`
endef
endif
+endif
ifeq ($(CONFIG_NAND_SUPPORT),)
define Package/base-files/nand-support