aboutsummaryrefslogtreecommitdiffstats
path: root/package/b43/src/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-10-13 22:41:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-10-13 22:41:37 +0000
commit590a77f53aec7097db66fce28e10f89dbdf9b37e (patch)
tree0813195c231cff5cb31678f782013b7219bdf357 /package/b43/src/Makefile
parentca21ca62f4f9026c8d4f51db4afcff0b11a91625 (diff)
downloadupstream-590a77f53aec7097db66fce28e10f89dbdf9b37e.tar.gz
upstream-590a77f53aec7097db66fce28e10f89dbdf9b37e.tar.bz2
upstream-590a77f53aec7097db66fce28e10f89dbdf9b37e.zip
add b43
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9293 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/b43/src/Makefile')
-rw-r--r--package/b43/src/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/b43/src/Makefile b/package/b43/src/Makefile
new file mode 100644
index 0000000000..485e59e2df
--- /dev/null
+++ b/package/b43/src/Makefile
@@ -0,0 +1,20 @@
+# b43 core
+b43-y += main.o
+b43-y += tables.o
+b43-y += phy.o
+b43-y += sysfs.o
+b43-y += xmit.o
+b43-y += lo.o
+# b43 RFKILL button support
+b43-$(CONFIG_B43_RFKILL) += rfkill.o
+# b43 LED support
+b43-$(CONFIG_B43_LEDS) += leds.o
+# b43 PCMCIA support
+b43-$(CONFIG_B43_PCMCIA) += pcmcia.o
+# b43 debugging
+b43-$(CONFIG_B43_DEBUG) += debugfs.o
+# b43 DMA and PIO
+b43-$(CONFIG_B43_DMA) += dma.o
+b43-$(CONFIG_B43_PIO) += pio.o
+
+obj-$(CONFIG_B43) += b43.o