aboutsummaryrefslogtreecommitdiffstats
path: root/package/apex
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-11-02 08:37:46 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-11-02 08:37:46 +0000
commit199cd21c0635ac54477fcac3e5c44c955f4d758a (patch)
treea51e288f2b48fecde71a3cea8cef2e462dbf9058 /package/apex
parent548ae3d28a052f9bd48f88a3a183ff1237a27411 (diff)
downloadupstream-199cd21c0635ac54477fcac3e5c44c955f4d758a.tar.gz
upstream-199cd21c0635ac54477fcac3e5c44c955f4d758a.tar.bz2
upstream-199cd21c0635ac54477fcac3e5c44c955f4d758a.zip
package/apex: fix a compile issue
SVN-Revision: 23768
Diffstat (limited to 'package/apex')
-rw-r--r--package/apex/patches/001-compile_fix.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/apex/patches/001-compile_fix.patch b/package/apex/patches/001-compile_fix.patch
new file mode 100644
index 0000000000..8a25de6570
--- /dev/null
+++ b/package/apex/patches/001-compile_fix.patch
@@ -0,0 +1,20 @@
+--- a/Makefile
++++ b/Makefile
+@@ -444,7 +444,7 @@ ifeq ($(config-targets),1)
+ include $(srctree)/src/arch-$(SRCARCH)/Makefile
+ export KBUILD_DEFCONFIG
+
+-config %config: scripts_basic outputmakefile FORCE
++%config: scripts_basic outputmakefile FORCE
+ $(Q)mkdir -p include/linux include/config
+ $(Q)$(MAKE) $(build)=scripts/kconfig $@
+
+@@ -1585,7 +1585,7 @@ endif
+ $(Q)$(MAKE) $(build)=$(build-dir) $(target-dir)$(notdir $@)
+
+ # Modules
+-/ %/: prepare scripts FORCE
++%/: prepare scripts FORCE
+ $(cmd_crmodverdir)
+ $(Q)$(MAKE) KBUILD_MODULES=$(if $(CONFIG_MODULES),1) \
+ $(build)=$(build-dir)