aboutsummaryrefslogtreecommitdiffstats
path: root/package/alsa
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-14 14:26:40 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-14 14:26:40 +0000
commitafc9d921a73bdff8679b21e6ab2528c8355bd31a (patch)
treebb8a6cb4cf1e7430020817ed48be8a968d34d5bc /package/alsa
parentf1d6fb4be149cd364524ff1db63a3f8a98f7ab7e (diff)
downloadupstream-afc9d921a73bdff8679b21e6ab2528c8355bd31a.tar.gz
upstream-afc9d921a73bdff8679b21e6ab2528c8355bd31a.tar.bz2
upstream-afc9d921a73bdff8679b21e6ab2528c8355bd31a.zip
portability fix
SVN-Revision: 5082
Diffstat (limited to 'package/alsa')
-rw-r--r--package/alsa/Makefile1
-rw-r--r--package/alsa/patches/110-cp_command.patch20
2 files changed, 21 insertions, 0 deletions
diff --git a/package/alsa/Makefile b/package/alsa/Makefile
index 47ad4456bf..2ac0b9433b 100644
--- a/package/alsa/Makefile
+++ b/package/alsa/Makefile
@@ -67,6 +67,7 @@ define Build/Compile
ARCH="$(LINUX_KARCH)" \
CROSS_COMPILE="$(TARGET_CROSS)" \
c_opts="$(KERNEL_C_OPTS)" \
+ CP="$(CP)" \
all
endef
diff --git a/package/alsa/patches/110-cp_command.patch b/package/alsa/patches/110-cp_command.patch
new file mode 100644
index 0000000000..68499e8837
--- /dev/null
+++ b/package/alsa/patches/110-cp_command.patch
@@ -0,0 +1,20 @@
+diff -ur alsa.old/Makefile alsa.dev/Makefile
+--- alsa.old/Makefile 2006-10-14 07:07:48.000000000 -0700
++++ alsa.dev/Makefile 2006-10-14 07:08:45.000000000 -0700
+@@ -100,6 +100,7 @@
+ SUBDIRS += parisc
+ endif
+ CSUBDIRS += include test utils
++CP = cp -fPR
+
+ KCONFIG_FILES = $(shell find $(SND_TOPDIR) -name Kconfig) $(shell find $(SND_TOPDIR)/alsa-kernel/ -name Kconfig)
+
+@@ -115,7 +116,7 @@
+ if [ ! -d include/sound -a ! -L include/sound ]; then \
+ ln -sf ../alsa-kernel/include include/sound ; \
+ fi
+- cp -auvf include/version.h include/sound/version.h
++ $(CP) include/version.h include/sound/version.h
+
+ utils/mod-deps: utils/mod-deps.c
+ gcc utils/mod-deps.c -o utils/mod-deps