aboutsummaryrefslogtreecommitdiffstats
path: root/package/acx-mac80211
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-09-29 12:42:34 +0000
committerNicolas Thill <nico@openwrt.org>2007-09-29 12:42:34 +0000
commitcba0658b1331b7176801438f75af483880ae9cfb (patch)
tree0b567fa5a95d40b843b994a8a6cae4e2150a5e29 /package/acx-mac80211
parentb58e8c03f22867d572038d11621fe656cd5de607 (diff)
downloadupstream-cba0658b1331b7176801438f75af483880ae9cfb.tar.gz
upstream-cba0658b1331b7176801438f75af483880ae9cfb.tar.bz2
upstream-cba0658b1331b7176801438f75af483880ae9cfb.zip
disable acx & acx-mac80211 on atheros, renable check for CONFIG_MAC80211 in KCONFIG in acx-mac80211 so that it does not get built on pre 2.6.22
SVN-Revision: 9065
Diffstat (limited to 'package/acx-mac80211')
-rw-r--r--package/acx-mac80211/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/acx-mac80211/Makefile b/package/acx-mac80211/Makefile
index 7bc37ee84c..51a6ce37ff 100644
--- a/package/acx-mac80211/Makefile
+++ b/package/acx-mac80211/Makefile
@@ -26,12 +26,13 @@ ifeq ($(DUMP),)
include $(LINUX_DIR)/.config
endif
+# XXX: remove @!TARGET_* later when we have PCI support properly detected on all targets
define KernelPackage/acx-mac80211
SUBMENU:=Wireless Drivers
TITLE:=ACX111 Mac80211 driver
DESCRIPTION:=Driver for acx111 cards (Mac80211 version)
- DEPENDS:=@LINUX_2_6 +kmod-mac80211
-# KCONFIG:=CONFIG_MAC80211
+ DEPENDS:=@LINUX_2_6 +kmod-mac80211 @!TARGET_atheros
+ KCONFIG:=CONFIG_MAC80211
FILES:=$(PKG_BUILD_DIR)/acx-mac80211.$(LINUX_KMOD_SUFFIX)
AUTOLOAD:=$(call AutoLoad,50,acx-mac80211)
endef