aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-08-26 17:31:27 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-08-26 17:31:27 +0000
commitf91d09cabb21d8f6011903174e2bafa3dc7f4f39 (patch)
tree08b7a7d0c5c020d2d26de01d4140ece615cee2a3 /package/Makefile
parenteaa8cb7834a1f0bf86973cdb0bba53eef6517e92 (diff)
downloadupstream-f91d09cabb21d8f6011903174e2bafa3dc7f4f39.tar.gz
upstream-f91d09cabb21d8f6011903174e2bafa3dc7f4f39.tar.bz2
upstream-f91d09cabb21d8f6011903174e2bafa3dc7f4f39.zip
mklibs: Fix mklibs usage when *.so files reside in subdirs
Currently package/Makefile only passes /lib /usr/lib and /usr/lib/ebtables to mklibs. However, other libs can also reside in different subdirectories (in my case /usr/lib/ipsec). Hence, create the list of library directories dynamically. Signed-off-by: Helmut Schaa <helmut.schaa@googlemail.com> SVN-Revision: 37841
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/package/Makefile b/package/Makefile
index f8002348b1..00ac773499 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -34,20 +34,18 @@ ifdef CONFIG_USE_MKLIBS
# find all loadable objects that are not regular libraries and add them to the list as well
find $(STAGING_DIR_ROOT) -type f -name \*.so\* -exec \
file -r -N -F '' {} + | \
- awk ' /shared object/ { print $$1 }' >> $(TMP_DIR)/mklibs-progs
+ awk ' /shared object/ { print $$1 }' > $(TMP_DIR)/mklibs-libs
mkdir -p $(TMP_DIR)/mklibs-out
$(STAGING_DIR_HOST)/bin/mklibs -D \
-d $(TMP_DIR)/mklibs-out \
--sysroot $(STAGING_DIR_ROOT) \
- -L /lib \
- -L /usr/lib \
- -L /usr/lib/ebtables \
+ `cat $(TMP_DIR)/mklibs-libs | sed 's:/*[^/]\+/*$$::' | uniq | sed 's:^$(STAGING_DIR_ROOT):-L :'` \
--ldlib $(patsubst $(STAGING_DIR_ROOT)/%,/%,$(firstword $(wildcard \
$(foreach name,ld-uClibc.so.* ld-linux.so.* ld-*.so, \
$(STAGING_DIR_ROOT)/lib/$(name) \
)))) \
--target $(REAL_GNU_TARGET_NAME) \
- `cat $(TMP_DIR)/mklibs-progs` 2>&1
+ `cat $(TMP_DIR)/mklibs-progs $(TMP_DIR)/mklibs-libs` 2>&1
$(RSTRIP) $(TMP_DIR)/mklibs-out
for lib in `ls $(TMP_DIR)/mklibs-out/*.so.* 2>/dev/null`; do \
LIB="$${lib##*/}"; \