aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2017-03-05 16:17:17 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2017-05-02 22:10:50 +0800
commitdac629f71093715ea002c7949a9888188e58984e (patch)
treee2bb34130d98ce9fc4c64a98ce4cd8cb850f08f6 /package/Makefile
parent60081f9a0072c2a5caecea617e84a9d2001f7f07 (diff)
downloadupstream-dac629f71093715ea002c7949a9888188e58984e.tar.gz
upstream-dac629f71093715ea002c7949a9888188e58984e.tar.bz2
upstream-dac629f71093715ea002c7949a9888188e58984e.zip
build: cleanup tmp/ dir of target rootfs
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/Makefile b/package/Makefile
index ac8faecef2..4fdf415046 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -63,7 +63,7 @@ endif
$(curdir)/install: $(TMP_DIR)/.build $(curdir)/merge $(if $(CONFIG_TARGET_PER_DEVICE_ROOTFS),$(curdir)/merge-index)
- find $(STAGING_DIR_ROOT) -type d | $(XARGS) chmod 0755
rm -rf $(TARGET_DIR) $(TARGET_DIR_ORIG)
- [ -d $(TARGET_DIR)/tmp ] || mkdir -p $(TARGET_DIR)/tmp
+ mkdir -p $(TARGET_DIR)/tmp
$(call opkg,$(TARGET_DIR)) install \
$(call opkg_package_files,$(shell cat $(PACKAGE_INSTALL_FILES) 2>/dev/null))
@for file in $(PACKAGE_INSTALL_FILES); do \