aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-09-11 12:27:49 +0000
committerJohn Crispin <john@openwrt.org>2014-09-11 12:27:49 +0000
commitd6dbc22bbcde78bbc378ca3f006771a2b074ff2e (patch)
tree0491fe2f49e0922ca3bad202ecfd9ee51dc5a1a5 /package/Makefile
parent285012d8972b1891c78d9d77b8a2f7d4e81ae829 (diff)
downloadupstream-d6dbc22bbcde78bbc378ca3f006771a2b074ff2e.tar.gz
upstream-d6dbc22bbcde78bbc378ca3f006771a2b074ff2e.tar.bz2
upstream-d6dbc22bbcde78bbc378ca3f006771a2b074ff2e.zip
ipkg: add a default postinst/prerm script
the postinst script enables/starts the init.d scripts upon package installation and installs the users required by the package. the prerm script stops and disables the init.d scripts. Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 42470
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/Makefile b/package/Makefile
index 0cba878576..a42b4b0dd0 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -116,7 +116,8 @@ $(curdir)/install: $(TMP_DIR)/.build
@-find $(TARGET_DIR) -name CVS | $(XARGS) rm -rf
@-find $(TARGET_DIR) -name .svn | $(XARGS) rm -rf
@-find $(TARGET_DIR) -name '.#*' | $(XARGS) rm -f
- rm -f $(TARGET_DIR)/usr/lib/opkg/info/*.postinst
+ rm -f $(TARGET_DIR)/usr/lib/opkg/info/*.postinst*
+ rm -f $(TARGET_DIR)/usr/lib/opkg/info/*.prerm*
$(if $(CONFIG_CLEAN_IPKG),rm -rf $(TARGET_DIR)/usr/lib/opkg)
$(call mklibs)