aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2016-04-17 12:50:30 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2016-04-17 12:50:30 +0000
commitca77367dae317ea79150e86decf6943e766c0745 (patch)
treea093b64f5199482639c656fff6cb0daf2b8825f9 /package/Makefile
parentea6d36111ba9d76ba46b9382d47283aa015e7039 (diff)
downloadupstream-ca77367dae317ea79150e86decf6943e766c0745.tar.gz
upstream-ca77367dae317ea79150e86decf6943e766c0745.tar.bz2
upstream-ca77367dae317ea79150e86decf6943e766c0745.zip
package: remove .git files from images
If you have your ./files/ directory stored in a git repository, the .git will be included into images using precious space. This patch removes .git directories before packing images. Signed-off-by: Joerg Jungermann <jj@borkum.net> Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 49180
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/Makefile b/package/Makefile
index c97e2c18d1..e0bd75ba7f 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -123,6 +123,7 @@ $(curdir)/install: $(TMP_DIR)/.build $(curdir)/system/opkg/host/install
$(if $(SOURCE_DATE_EPOCH),sed -i "s/Installed-Time: .*/Installed-Time: $(SOURCE_DATE_EPOCH)/" $(TARGET_DIR)/usr/lib/opkg/status)
@-find $(TARGET_DIR) -name CVS | $(XARGS) rm -rf
@-find $(TARGET_DIR) -name .svn | $(XARGS) rm -rf
+ @-find $(TARGET_DIR) -name .git | $(XARGS) rm -rf
@-find $(TARGET_DIR) -name '.#*' | $(XARGS) rm -f
rm -f $(TARGET_DIR)/usr/lib/opkg/info/*.postinst*
rm -f $(TARGET_DIR)/usr/lib/opkg/info/*.prerm*