aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorMatteo Croce <rootkit85@yahoo.it>2015-06-25 10:14:22 +0000
committerMatteo Croce <rootkit85@yahoo.it>2015-06-25 10:14:22 +0000
commitc37d7a7e8f35e2f0ffa3a5dac89cea138f5ca193 (patch)
treeb414f916ffb0ff0a03ee24b4f3327da954b17797 /package/Makefile
parent9bdae8fc1ef7b4477bd998ee8272cff66c83fff7 (diff)
downloadupstream-c37d7a7e8f35e2f0ffa3a5dac89cea138f5ca193.tar.gz
upstream-c37d7a7e8f35e2f0ffa3a5dac89cea138f5ca193.tar.bz2
upstream-c37d7a7e8f35e2f0ffa3a5dac89cea138f5ca193.zip
fix mklibs with musl
crate a relative symlink to libc.so because make wildcard function ignores broken symlinks SVN-Revision: 46123
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/Makefile b/package/Makefile
index 5fb7363bc9..3ef34b1779 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -41,7 +41,7 @@ ifdef CONFIG_USE_MKLIBS
--sysroot $(STAGING_DIR_ROOT) \
`cat $(TMP_DIR)/mklibs-libs | sed 's:/*[^/]\+/*$$::' | uniq | sed 's:^$(STAGING_DIR_ROOT):-L :'` \
--ldlib $(patsubst $(STAGING_DIR_ROOT)/%,/%,$(firstword $(wildcard \
- $(foreach name,ld-uClibc.so.* ld-linux.so.* ld-*.so, \
+ $(foreach name,ld-uClibc.so.* ld-linux.so.* ld-*.so ld-musl-*.so.*, \
$(STAGING_DIR_ROOT)/lib/$(name) \
)))) \
--target $(REAL_GNU_TARGET_NAME) \