aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-06-14 17:42:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-06-14 17:42:05 +0000
commitb35846974ea171def35c6fc7ad694a05f4b42748 (patch)
treed050981702c429cc19c9a1cd234c6331b153829b /package/Makefile
parentc41a1affb875e6a6f073139482ca0b9d5e5251f8 (diff)
downloadupstream-b35846974ea171def35c6fc7ad694a05f4b42748.tar.gz
upstream-b35846974ea171def35c6fc7ad694a05f4b42748.tar.bz2
upstream-b35846974ea171def35c6fc7ad694a05f4b42748.zip
build: do another init script enabling run, fixes init scripts added via files/ (#19857)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 45964
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/Makefile b/package/Makefile
index a601dcbb31..5fb7363bc9 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -111,6 +111,10 @@ $(curdir)/install: $(TMP_DIR)/.build
cd $(TARGET_DIR); \
for script in ./usr/lib/opkg/info/*.postinst; do \
IPKG_INSTROOT=$(TARGET_DIR) $$(which bash) $$script; \
+ done; \
+ for script in ./etc/init.d/*; do \
+ grep '#!/bin/sh /etc/rc.common' $$script >/dev/null || continue; \
+ IPKG_INSTROOT=$(TARGET_DIR) $$(which bash) ./etc/rc.common $$script enable; \
done || true \
)
@-find $(TARGET_DIR) -name CVS | $(XARGS) rm -rf