aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-08-07 15:35:12 +0000
committerJo-Philipp Wich <jow@openwrt.org>2014-08-07 15:35:12 +0000
commitaebbc47c2af536d35cebf0f5face326f779286fe (patch)
tree0aa49422df9b38c42fb9e355720487e8cb402f33 /package/Makefile
parentbc67bd229555f708717cd7647429f64b4c563a52 (diff)
downloadupstream-aebbc47c2af536d35cebf0f5face326f779286fe.tar.gz
upstream-aebbc47c2af536d35cebf0f5face326f779286fe.tar.bz2
upstream-aebbc47c2af536d35cebf0f5face326f779286fe.zip
build: consider sub-directories when deploying packages to image with CONFIG_PER_FEED_REPO (#17430)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 42041
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/Makefile b/package/Makefile
index bf1b16fc9a..0cba878576 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -94,7 +94,7 @@ $(curdir)/install: $(TMP_DIR)/.build
- find $(STAGING_DIR_ROOT) -type d | $(XARGS) chmod 0755
rm -rf $(TARGET_DIR)
[ -d $(TARGET_DIR)/tmp ] || mkdir -p $(TARGET_DIR)/tmp
- @$(FIND) `sed -e 's|.*|$(PACKAGE_DIR)/&_*.ipk|' $(PACKAGE_INSTALL_FILES)` | sort -u | $(OPKG) install
+ @$(FIND) `sed -e 's|.*|$(PACKAGE_DIR)$(if $(CONFIG_PER_FEED_REPO),/*)/&_*.ipk|' $(PACKAGE_INSTALL_FILES)` | sort -u | $(OPKG) install
@for file in $(PACKAGE_INSTALL_FILES); do \
[ -s $$file.flags ] || continue; \
for flag in `cat $$file.flags`; do \