aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-02-20 12:37:58 +0100
committerFelix Fietkau <nbd@nbd.name>2017-02-21 13:03:20 +0100
commitadeae0e02a8cd0e67fc5ba549591fefb056011e7 (patch)
tree3a142c20d50cb1eaac682c84e155975c41cd22b6 /package/Makefile
parent294e908a2cb53ab4ea34e202a31fc941a4825e16 (diff)
downloadupstream-adeae0e02a8cd0e67fc5ba549591fefb056011e7.tar.gz
upstream-adeae0e02a8cd0e67fc5ba549591fefb056011e7.tar.bz2
upstream-adeae0e02a8cd0e67fc5ba549591fefb056011e7.zip
build: move opkg host dependency from package/install to package/compile
Improves parallel build behavior, since it allows opkg to be built at the same time as other packages Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/Makefile b/package/Makefile
index fd0e88ff38..1ef501736b 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -56,7 +56,9 @@ $(curdir)/merge:
$(curdir)/merge-index: $(curdir)/merge
(cd $(PACKAGE_DIR_ALL) && $(SCRIPT_DIR)/ipkg-make-index.sh . 2>&1 > Packages; )
-$(curdir)/install: $(TMP_DIR)/.build $(curdir)/system/opkg/host/compile $(curdir)/merge $(if $(CONFIG_TARGET_PER_DEVICE_ROOTFS),$(curdir)/merge-index)
+$(curdir)/compile: $(curdir)/system/opkg/host/compile
+
+$(curdir)/install: $(TMP_DIR)/.build $(curdir)/merge $(if $(CONFIG_TARGET_PER_DEVICE_ROOTFS),$(curdir)/merge-index)
- find $(STAGING_DIR_ROOT) -type d | $(XARGS) chmod 0755
rm -rf $(TARGET_DIR) $(TARGET_DIR_ORIG)
[ -d $(TARGET_DIR)/tmp ] || mkdir -p $(TARGET_DIR)/tmp