aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-31 23:29:12 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-31 23:29:12 +0000
commitad8169546cbcb5b2ed59cef332bb6b1dc5e389ef (patch)
tree4408421dfcde5a22705165b8d7ff06f6cd3e429e /package/Makefile
parent82522dbaee8cd5f94267ebf465e36d594e4d2d7a (diff)
downloadupstream-ad8169546cbcb5b2ed59cef332bb6b1dc5e389ef.tar.gz
upstream-ad8169546cbcb5b2ed59cef332bb6b1dc5e389ef.tar.bz2
upstream-ad8169546cbcb5b2ed59cef332bb6b1dc5e389ef.zip
package/Makefile: override opkg installation time when SOURCE_DATE_EPOCH set
Signed-off-by: Alexander Couzens <lynxis@fe80.eu> Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 48585
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/Makefile b/package/Makefile
index 12bd0ae0c2..1a78fde47a 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -117,6 +117,7 @@ $(curdir)/install: $(TMP_DIR)/.build $(curdir)/system/opkg/host/install
IPKG_INSTROOT=$(TARGET_DIR) $$(which bash) ./etc/rc.common $$script enable; \
done || true \
)
+ $(if $(SOURCE_DATE_EPOCH),sed -i "s/Installed-Time: .*/Installed-Time: $(SOURCE_DATE_EPOCH)/" $(TARGET_DIR)/usr/lib/opkg/status)
@-find $(TARGET_DIR) -name CVS | $(XARGS) rm -rf
@-find $(TARGET_DIR) -name .svn | $(XARGS) rm -rf
@-find $(TARGET_DIR) -name '.#*' | $(XARGS) rm -f