aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-10 13:02:33 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-10 13:44:25 +0100
commit9cdf852ae09e8b418d9ab5c462b95742dc2f0fc2 (patch)
tree2e2dd387b5f65fab4d62aa1bc8e2730bb0f8f57c /package/Makefile
parentf5c649d7c61844d80b78d9fc945aec54bfbd7e44 (diff)
downloadupstream-9cdf852ae09e8b418d9ab5c462b95742dc2f0fc2.tar.gz
upstream-9cdf852ae09e8b418d9ab5c462b95742dc2f0fc2.tar.bz2
upstream-9cdf852ae09e8b418d9ab5c462b95742dc2f0fc2.zip
opkg: drop S/MIME support
It has never been used by default (due to being too bloated), and it is properly replaced by usign (which has been the default for a long time now). Remove this feature to simplify the build system Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile28
1 files changed, 0 insertions, 28 deletions
diff --git a/package/Makefile b/package/Makefile
index 17378a95ef..3250e7b7d0 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -74,15 +74,6 @@ $(curdir)/install: $(TMP_DIR)/.build $(curdir)/system/opkg/host/install $(curdir
$(call prepare_rootfs,$(TARGET_DIR))
-PASSOPT=""
-PASSARG=""
-ifndef CONFIG_OPKGSMIME_PASSPHRASE
- ifneq ($(call qstrip,$(CONFIG_OPKGSMIME_PASSFILE)),)
- PASSOPT="-passin"
- PASSARG="file:$(call qstrip,$(CONFIG_OPKGSMIME_PASSFILE))"
- endif
-endif
-
$(curdir)/index: FORCE
@echo Generating package index...
@for d in $(PACKAGE_SUBDIRS); do ( \
@@ -99,25 +90,6 @@ ifdef CONFIG_SIGNED_PACKAGES
cd $$d || continue; \
$(STAGING_DIR_HOST)/bin/usign -S -m Packages -s $(BUILD_KEY); \
); done
-else
-ifeq ($(call qstrip,$(CONFIG_OPKGSMIME_KEY)),)
- @echo Signing key has not been configured
-else
-ifeq ($(call qstrip,$(CONFIG_OPKGSMIME_CERT)),)
- @echo Certificate has not been configured
-else
- @echo Signing package index...
- @for d in $(PACKAGE_SUBDIRS); do ( \
- [ -d $$d ] && \
- cd $$d || continue; \
- openssl smime -binary -in Packages.gz \
- -out Packages.sig -outform PEM -sign \
- -signer $(CONFIG_OPKGSMIME_CERT) \
- -inkey $(CONFIG_OPKGSMIME_KEY) \
- $(PASSOPT) $(PASSARG); \
- ); done
-endif
-endif
endif
$(curdir)/preconfig: