aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-18 15:37:57 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-18 23:57:08 +0100
commit7a523569f7f403cdd7c2074cc49920f1dd7ecc70 (patch)
tree1fb09d1838718e062e74c7894a3f65b8523cfa31 /package/Makefile
parentc150a190f59afa3d34924a76bb9306bdb0914533 (diff)
downloadupstream-7a523569f7f403cdd7c2074cc49920f1dd7ecc70.tar.gz
upstream-7a523569f7f403cdd7c2074cc49920f1dd7ecc70.tar.bz2
upstream-7a523569f7f403cdd7c2074cc49920f1dd7ecc70.zip
build: add support for automatically removing build dir contents during build
This is used to save space on buildbot instances. If any part of a package needs to be rebuild, the whole package is rebuilt from scratch. Stamp files are preserved to allow dependency checks to work Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/Makefile b/package/Makefile
index 3250e7b7d0..3cf500d461 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -10,6 +10,7 @@ curdir:=package
include $(INCLUDE_DIR)/rootfs.mk
-include $(TMP_DIR)/.packagedeps
+$(curdir)/autoremove:=1
$(curdir)/builddirs:=$(sort $(package-) $(package-y) $(package-m))
$(curdir)/builddirs-install:=.
$(curdir)/builddirs-default:=. $(sort $(package-y) $(package-m))