aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-12-14 15:36:39 +0100
committerFelix Fietkau <nbd@nbd.name>2016-12-17 10:36:25 +0100
commit7a315b0b5d6aa91695853a8647383876e4b49a7a (patch)
treeca99d91b9ec9408e37d30f2983847fc5a500d4a7 /package/Makefile
parent720b99215da295a2e7b4acdef30b58bec6acedc2 (diff)
downloadupstream-7a315b0b5d6aa91695853a8647383876e4b49a7a.tar.gz
upstream-7a315b0b5d6aa91695853a8647383876e4b49a7a.tar.bz2
upstream-7a315b0b5d6aa91695853a8647383876e4b49a7a.zip
build: implement make check and make package/X/check
This is intended to be used for a wide array of package sanity checks. The first check that is implemented is for the hash of downloaded files. It checks: - Missing hash - Use of SHA256 instead of MD5 - dl/<file> hash not matching hash in makefile - deprecated MD5SUM variable The deprecated MD5SUM variable check is skipped for feeds/ until OpenWrt is updated as well Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/Makefile b/package/Makefile
index 8726e2eae9..c4fb8ca974 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -123,5 +123,6 @@ $(eval $(call stampfile,$(curdir),package,prereq,.config))
$(eval $(call stampfile,$(curdir),package,cleanup,$(TMP_DIR)/.build))
$(eval $(call stampfile,$(curdir),package,compile,$(TMP_DIR)/.build))
$(eval $(call stampfile,$(curdir),package,install,$(TMP_DIR)/.build))
+$(eval $(call stampfile,$(curdir),package,check,$(TMP_DIR)/.build))
$(eval $(call subdir,$(curdir)))