aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-08-15 10:57:03 -1000
committerDaniel Golle <daniel@makrotopia.org>2020-08-31 11:18:06 +0100
commit62d5ec7306f9664aeba64bc64c0dee1d93978bb4 (patch)
tree09597f31a7c33a4236c94aace208e05a4127dd25 /package/Makefile
parentfd29f2bcd97f7af7de22ac95b1490a54f45d6c88 (diff)
downloadupstream-62d5ec7306f9664aeba64bc64c0dee1d93978bb4.tar.gz
upstream-62d5ec7306f9664aeba64bc64c0dee1d93978bb4.tar.bz2
upstream-62d5ec7306f9664aeba64bc64c0dee1d93978bb4.zip
build: store SourceDateEpoch in manifest
The usage of granular `SOURCE_DATE_EPOCH` for packages is an incrementing integer which could be useful for downstream tooling, therefore add it to the packages manifest. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/Makefile b/package/Makefile
index 58c1ba2bbf..f5373ee65d 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -84,7 +84,7 @@ $(curdir)/index: FORCE
mkdir -p $$d; \
cd $$d || continue; \
$(SCRIPT_DIR)/ipkg-make-index.sh . 2>&1 > Packages.manifest; \
- grep -vE '^(Maintainer|LicenseFiles|Source|SourceName|Require)' Packages.manifest > Packages; \
+ grep -vE '^(Maintainer|LicenseFiles|Source|SourceName|Require|SourceDateEpoch)' Packages.manifest > Packages; \
case "$$(((64 + $$(stat -L -c%s Packages)) % 128))" in 110|111) \
$(call ERROR_MESSAGE,WARNING: Applying padding in $$d/Packages to workaround usign SHA-512 bug!); \
{ echo ""; echo ""; } >> Packages;; \