aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-02-26 00:41:53 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-02-26 00:41:53 +0000
commit4e60cfe51f97990eb1244e2813d12d514a761d7c (patch)
tree749e7e6f5d61542cf615708ad9f61565d65a9655 /package/Makefile
parent27fd6cee569095e3bdc4b394e0e89aac9a9bdddc (diff)
downloadupstream-4e60cfe51f97990eb1244e2813d12d514a761d7c.tar.gz
upstream-4e60cfe51f97990eb1244e2813d12d514a761d7c.tar.bz2
upstream-4e60cfe51f97990eb1244e2813d12d514a761d7c.zip
use default_subtargets in package/Makefile and target/Makefile
SVN-Revision: 6380
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile15
1 files changed, 1 insertions, 14 deletions
diff --git a/package/Makefile b/package/Makefile
index 6ddbc1ba45..151942de34 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -22,20 +22,7 @@ $(STAMP_DIR) $(TARGET_DIR):
%-prereq: $(STAMP_DIR) $(TARGET_DIR)
$(MAKE) -C $(patsubst %-prereq,%,$@) prereq
-%-download: $(STAMP_DIR) $(TARGET_DIR)
- $(MAKE) -C $(patsubst %-download,%,$@) download
-
-%-prepare: $(STAMP_DIR) $(TARGET_DIR)
- $(MAKE) -C $(patsubst %-prepare,%,$@) prepare
-
-%-compile: $(STAMP_DIR) $(TARGET_DIR)
- $(MAKE) -C $(patsubst %-compile,%,$@) compile
-
-%-install: $(STAMP_DIR) $(TARGET_DIR)
- $(MAKE) -C $(patsubst %-install,%,$@) install
-
-%-clean: $(STAMP_DIR) $(TARGET_DIR)
- $(MAKE) -C $(patsubst %-clean,%,$@) clean
+$(eval $(call default_subtargets,$(TARGET_DIR)))
ifeq ($(SDK),1)
GENDEP_OPTS := -s