aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-07-18 16:44:44 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-07-18 16:44:44 +0000
commit4af1bb818c0c9784cb402e8a88546f69e2f1691e (patch)
tree9a3d143337c2c4097568fa3bfc3023a5fc695d5a /package/Makefile
parent58f50a7dbd8329e96b6edc752c3aa1fc3b32cc61 (diff)
downloadupstream-4af1bb818c0c9784cb402e8a88546f69e2f1691e.tar.gz
upstream-4af1bb818c0c9784cb402e8a88546f69e2f1691e.tar.bz2
upstream-4af1bb818c0c9784cb402e8a88546f69e2f1691e.zip
build: fix IGNORE_ERRORS for sources packages that match both 'y' and 'm'
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 37405
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/package/Makefile b/package/Makefile
index df7cf79f2e..f8002348b1 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -16,7 +16,12 @@ else
$(curdir)/builddirs-prereq:=. $(sort $(prereq-y) $(prereq-m))
endif
ifneq ($(IGNORE_ERRORS),)
- $(curdir)/builddirs-ignore-compile:= $(if $(filter n m y, $(IGNORE_ERRORS)),$(foreach m,$(IGNORE_ERRORS),$(package-$(subst n,,$(m)))),$(package-m) $(package-))
+ package-y-filter := $(package-y)
+ package-m-filter := $(filter-out $(package-y),$(package-m))
+ package-n-filter := $(filter-out $(package-y) $(package-m),$(package-))
+ package-ignore-errors := $(filter n m y,$(IGNORE_ERRORS))
+ package-ignore-errors := $(if $(package-ignore-errors),$(package-ignore-errors),n m)
+ $(curdir)/builddirs-ignore-compile := $(foreach m,$(package-ignore-errors),$(package-$(m)-filter))
endif
ifdef CONFIG_USE_MKLIBS