aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-09-16 11:56:19 +0000
committerJohn Crispin <john@openwrt.org>2014-09-16 11:56:19 +0000
commit44249f71a863682ab2569c4794ed2a98bd59c1d9 (patch)
treee01492c520450e01200f2be5bde9f0f3e743b057 /package/Makefile
parentac01f2b9d6f83fcb63b03b48be1dddd6ca963c0f (diff)
downloadupstream-44249f71a863682ab2569c4794ed2a98bd59c1d9.tar.gz
upstream-44249f71a863682ab2569c4794ed2a98bd59c1d9.tar.bz2
upstream-44249f71a863682ab2569c4794ed2a98bd59c1d9.zip
postinst trigger: the new postinst trigger broke IB
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 42571
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/Makefile b/package/Makefile
index a42b4b0dd0..a6b34be0f4 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -59,6 +59,7 @@ endif
# where to build (and put) .ipk packages
OPKG:= \
+ IPKG_NO_SCRIPT=1 \
IPKG_TMP=$(TMP_DIR)/ipkg \
IPKG_INSTROOT=$(TARGET_DIR) \
IPKG_CONF_DIR=$(STAGING_DIR)/etc \
@@ -108,9 +109,8 @@ $(curdir)/install: $(TMP_DIR)/.build
@mkdir -p $(TARGET_DIR)/etc/rc.d
@( \
cd $(TARGET_DIR); \
- for script in ./etc/init.d/*; do \
- grep '#!/bin/sh /etc/rc.common' $$script >/dev/null || continue; \
- IPKG_INSTROOT=$(TARGET_DIR) $$(which bash) ./etc/rc.common $$script enable; \
+ for script in ./usr/lib/opkg/info/*.postinst; do \
+ IPKG_INSTROOT=$(TARGET_DIR) $$(which bash) $$script; \
done || true \
)
@-find $(TARGET_DIR) -name CVS | $(XARGS) rm -rf