aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-06-02 12:44:13 +0000
committerJohn Crispin <john@openwrt.org>2014-06-02 12:44:13 +0000
commit3936ed402896c4e35ba9a84cc31f92feecb0a139 (patch)
tree3c2e635490d0f7f3f8b6d7d7e05feeba57474d87 /package/Makefile
parent14421bd7fbc53ced274d758fe3d6fe53ee8c7b20 (diff)
downloadupstream-3936ed402896c4e35ba9a84cc31f92feecb0a139.tar.gz
upstream-3936ed402896c4e35ba9a84cc31f92feecb0a139.tar.bz2
upstream-3936ed402896c4e35ba9a84cc31f92feecb0a139.zip
package/Makefile: Substituted deprecated -perm +mode with -perm /mode
The find(1) -perm +mode is no longer supported and has been deprecated since 2005. This could resolve #13855 ticket. Signed-off-by: Rocco Folino <lordzen87@gmail.com> SVN-Revision: 40927
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/Makefile b/package/Makefile
index e189e37043..1930d27cf8 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -26,7 +26,7 @@ ifdef CONFIG_USE_MKLIBS
define mklibs
rm -rf $(TMP_DIR)/mklibs-progs $(TMP_DIR)/mklibs-out
# first find all programs and add them to the mklibs list
- find $(STAGING_DIR_ROOT) -type f -perm +100 -exec \
+ find $(STAGING_DIR_ROOT) -type f -perm /100 -exec \
file -r -N -F '' {} + | \
awk ' /executable.*dynamically/ { print $$1 }' > $(TMP_DIR)/mklibs-progs
# find all loadable objects that are not regular libraries and add them to the list as well