aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-22 13:30:39 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-22 13:31:54 +0100
commit2990a21058243b067bb56fed36ee69205595993e (patch)
tree500ca7bc63912d4c54891232000d882c81c00d3a /package/Makefile
parentf798776188eaf1a9c0345da66a848a5cbe3cfb71 (diff)
downloadupstream-2990a21058243b067bb56fed36ee69205595993e.tar.gz
upstream-2990a21058243b067bb56fed36ee69205595993e.tar.bz2
upstream-2990a21058243b067bb56fed36ee69205595993e.zip
build: always run package/cleanup before package/compile
Remove unnecessary stampfile indirection Fixes an issue with the command sequence used by buildbot Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/Makefile b/package/Makefile
index 6929c479a2..b5e4bfa12b 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -49,6 +49,8 @@ PACKAGE_INSTALL_FILES:= \
$(curdir)/cleanup: $(TMP_DIR)/.build
rm -rf $(STAGING_DIR_ROOT)
+$(curdir)/compile: $(curdir)/cleanup
+
$(curdir)/merge:
rm -rf $(PACKAGE_DIR_ALL)
mkdir -p $(PACKAGE_DIR_ALL)
@@ -98,7 +100,6 @@ $(curdir)/preconfig:
$(curdir)/flags-install:= -j1
$(eval $(call stampfile,$(curdir),package,prereq,.config))
-$(eval $(call stampfile,$(curdir),package,cleanup,$(TMP_DIR)/.build))
$(eval $(call stampfile,$(curdir),package,compile,$(TMP_DIR)/.build))
$(eval $(call stampfile,$(curdir),package,install,$(TMP_DIR)/.build))
$(eval $(call stampfile,$(curdir),package,check,$(TMP_DIR)/.build))