aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2017-01-19 02:41:02 +0100
committerJo-Philipp Wich <jo@mein.io>2017-01-19 02:44:08 +0100
commit1fb673ee12cad775acf8cb89fc8608e8c3c457a2 (patch)
tree77fa1e381e14239ab2ed4f3e6225935fc6e4b272 /package/Makefile
parent421a6d314a0c8a8ff9e8ede2677007e8fcac3919 (diff)
downloadupstream-1fb673ee12cad775acf8cb89fc8608e8c3c457a2.tar.gz
upstream-1fb673ee12cad775acf8cb89fc8608e8c3c457a2.tar.bz2
upstream-1fb673ee12cad775acf8cb89fc8608e8c3c457a2.zip
build: fix triggering opkg/host compilation
Commit 131db36 "build: remove separate /install step for host builds" dropped the package/*/host/install targets in favor to performing the install steps within the compile target instead. Adjust package/Makefile accordingly in order to prevent a missing staging_dir/host/bin/opkg when staging package archives into the rootfs. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/Makefile b/package/Makefile
index 3cf500d461..6929c479a2 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -57,7 +57,7 @@ $(curdir)/merge:
$(curdir)/merge-index: $(curdir)/merge
(cd $(PACKAGE_DIR_ALL) && $(SCRIPT_DIR)/ipkg-make-index.sh . 2>&1 > Packages; )
-$(curdir)/install: $(TMP_DIR)/.build $(curdir)/system/opkg/host/install $(curdir)/merge $(if $(CONFIG_TARGET_PER_DEVICE_ROOTFS),$(curdir)/merge-index)
+$(curdir)/install: $(TMP_DIR)/.build $(curdir)/system/opkg/host/compile $(curdir)/merge $(if $(CONFIG_TARGET_PER_DEVICE_ROOTFS),$(curdir)/merge-index)
- find $(STAGING_DIR_ROOT) -type d | $(XARGS) chmod 0755
rm -rf $(TARGET_DIR) $(TARGET_DIR_ORIG)
[ -d $(TARGET_DIR)/tmp ] || mkdir -p $(TARGET_DIR)/tmp