aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-08-01 11:12:15 +0200
committerFelix Fietkau <nbd@nbd.name>2016-08-01 11:13:38 +0200
commit180465c38f1599f7339a00f80b383620c7c3818d (patch)
treec17d046a50456c32b484f97b5274bcff3c3456f4 /package/Makefile
parente351f7c695760b50ef9ab8a08907d443dc5ea585 (diff)
downloadupstream-180465c38f1599f7339a00f80b383620c7c3818d.tar.gz
upstream-180465c38f1599f7339a00f80b383620c7c3818d.tar.bz2
upstream-180465c38f1599f7339a00f80b383620c7c3818d.zip
build: create a package feed directory containing all packages
Needed for proper dependency handling for per-device rootfs Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/package/Makefile b/package/Makefile
index f5a7395643..9f39395bae 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -44,7 +44,15 @@ PACKAGE_INSTALL_FILES:= \
$(curdir)/cleanup: $(TMP_DIR)/.build
rm -rf $(STAGING_DIR_ROOT)
-$(curdir)/install: $(TMP_DIR)/.build $(curdir)/system/opkg/host/install
+$(curdir)/merge:
+ rm -rf $(PACKAGE_DIR_ALL)
+ mkdir -p $(PACKAGE_DIR_ALL)
+ -$(foreach pdir,$(PACKAGE_SUBDIRS),$(if $(wildcard $(pdir)/*.ipk),ln -s $(pdir)/*.ipk $(PACKAGE_DIR_ALL);))
+
+$(curdir)/merge-index: $(curdir)/merge
+ (cd $(PACKAGE_DIR_ALL) && $(SCRIPT_DIR)/ipkg-make-index.sh . 2>&1 > Packages; )
+
+$(curdir)/install: $(TMP_DIR)/.build $(curdir)/system/opkg/host/install $(curdir)/merge $(if $(CONFIG_TARGET_PER_DEVICE_ROOTFS),$(curdir)/merge-index)
- find $(STAGING_DIR_ROOT) -type d | $(XARGS) chmod 0755
rm -rf $(TARGET_DIR)
[ -d $(TARGET_DIR)/tmp ] || mkdir -p $(TARGET_DIR)/tmp